The Energy Detective Forums

General Category => TED5000 Support => Topic started by: Guest on November 18, 2020, 08:54:36 PM

Title: Cannot Update Utility Rates
Post by: Guest on November 18, 2020, 08:54:36 PM
I have several gateways. None will allow me to update the utility rates for TOU rate plan. Running gateway firmware version 1.0.449 on most of these.  What is the latest version available?
Title: Re: Cannot Update Utility Rates
Post by: Guest on January 06, 2021, 06:58:00 PM
I'm having the same problem with updating Utility Rates and I also can't update the Load Profile settings. 

This is on a TED 5000 system that is fairly old and I'm attempting to reinstall in a new location.  Initially I also noted that the time was not being maintained and some of the System settings were not being saved, specifically the Dashboard settings under the Footprint Settings tab.  I found a youtube video that showed replacing the battery in the Gateway and I thought that might be the problem. I verified that the existing battery was dead and replaced it with a new one. That did fix the problem with the clock and the System settings.

I can now update those settings in the Gateway and the changes stick.  I was very hopeful that it would also fix the problem with the Utility and Load settings, but unfortunately, it doesn't seem to have helped with that.  When I try to do an update of the gateway with changes in either of those two categories, it goes through the steps and reports success, but when I go back and look at the settings on the gateway, I see that they haven't changed.

I know it's a long shot asking for help on this forum because it doesn't look like there is much activity here anymore, but I wanted to at least try and see if anyone has additional insights about how the Utility and Load settings are stored on the gateway that might be different than how the System settings are stored.

I also want to suggest to others that if your gateway is very old and you are having troubles with it keeping time or other values, it may well be that the CR2032 Lithium battery in the gateway has died and needs to be replaced. Unfortunately, it's soldered in, so replacement is not trivial, but it's not terribly difficult if you know how to solder electronics.
Title: Re: Cannot Update Utility Rates
Post by: Guest on February 28, 2021, 12:06:53 PM
I had this same problem. I have 7 gateways and after a recent rate change, I could not get changes to the rates to update. I tried chrome and firefox browsers. Still no joy.
I solved the problem by firing up an old Win-XP machine that was connected to my network. I loaded footprints for each gateway one by one and going thru each of settings menus, I updated the rates and then saved them. They all updated. I am guessing it was a browser issue as I used IE browser on the WIN-XP which is not available on my Win-10 machine.

Interested if anyone finds another solution.